<!DOCTYPE html>
<!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" class="no-js"><!--<![endif]-->
<head>
<meta charset="utf-8">

<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->

<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="pingback" href="https://www.youredm.com/xmlrpc.php">

<script type="application/ld+json">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</script>
<title>Your EDM&#039;s Top 10 Albums Of 2019 | Your EDM</title>

<meta name="description" content="These past few years, at least since Your EDM has been keeping track of Top 10 Albums of the year, have been a phenomenal resurgence of the long-play" />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Your EDM&#039;s Top 10 Albums Of 2019" />
<meta property="og:description" content="These past few years, at least since Your EDM has been keeping track of Top 10 Albums of the year, have been a phenomenal resurgence of the long-play" />
<meta property="og:url" content="https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/" />
<meta property="og:site_name" content="Your EDM" />
<meta property="article:publisher" content="https://www.facebook.com/YourEdm" />
<meta property="article:author" content="https://www.facebook.com/matcheeew" />
<meta property="article:tag" content="2019" />
<meta property="article:tag" content="avicii" />
<meta property="article:tag" content="Big Wild" />
<meta property="article:tag" content="delta heavy" />
<meta property="article:tag" content="dj snake" />
<meta property="article:tag" content="Flume" />
<meta property="article:tag" content="Fox Stevenson" />
<meta property="article:tag" content="ILLENIUM" />
<meta property="article:tag" content="karma fields" />
<meta property="article:tag" content="list" />
<meta property="article:tag" content="madeon" />
<meta property="article:tag" content="sebastian" />
<meta property="article:tag" content="top 10 albums" />
<meta property="article:tag" content="top 10 albums 2019" />
<meta property="article:section" content="EDM News" />
<meta property="article:published_time" content="2019-12-23T20:45:58+00:00" />
<meta property="article:modified_time" content="2019-12-23T21:00:00+00:00" />
<meta property="og:updated_time" content="2019-12-23T21:00:00+00:00" />
<meta property="og:image" content="https://www.youredm.com/wp-content/uploads/2019/11/Madeon_Amsterdam_Sebdevinc-6-1024x683.jpg" />
<meta property="og:image:secure_url" content="https://www.youredm.com/wp-content/uploads/2019/11/Madeon_Amsterdam_Sebdevinc-6-1024x683.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="683" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="These past few years, at least since Your EDM has been keeping track of Top 10 Albums of the year, have been a phenomenal resurgence of the long-play" />
<meta name="twitter:title" content="Your EDM&#039;s Top 10 Albums Of 2019 | Your EDM" />
<meta name="twitter:site" content="@YourEDM" />
<meta name="twitter:image" content="https://www.youredm.com/wp-content/uploads/2019/11/Madeon_Amsterdam_Sebdevinc-6.jpg" />
<meta name="twitter:creator" content="@themattmeadow" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.youredm.com/#organization","name":"Your EDM","url":"https://www.youredm.com/","sameAs":["https://www.facebook.com/YourEdm","https://www.instagram.com/YourEDM","https://www.linkedin.com/company/your-edm","https://www.youtube.com/user/YourEDMTV","https://twitter.com/YourEDM"],"logo":{"@type":"ImageObject","@id":"https://www.youredm.com/#logo","url":"https://www.youredm.com/wp-content/uploads/2014/11/180x180-black-on-white-logo.jpg","width":180,"height":180,"caption":"Your EDM"},"image":{"@id":"https://www.youredm.com/#logo"}},{"@type":"WebSite","@id":"https://www.youredm.com/#website","url":"https://www.youredm.com/","name":"Your EDM","publisher":{"@id":"https://www.youredm.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.youredm.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/#primaryimage","url":"https://www.youredm.com/wp-content/uploads/2019/11/Madeon_Amsterdam_Sebdevinc-6.jpg","width":2048,"height":1365,"caption":"madeon"},{"@type":"WebPage","@id":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/#webpage","url":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/","inLanguage":"en-US","name":"Your EDM&#039;s Top 10 Albums Of 2019 | Your EDM","isPartOf":{"@id":"https://www.youredm.com/#website"},"primaryImageOfPage":{"@id":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/#primaryimage"},"datePublished":"2019-12-23T20:45:58+00:00","dateModified":"2019-12-23T21:00:00+00:00","description":"These past few years, at least since Your EDM has been keeping track of Top 10 Albums of the year, have been a phenomenal resurgence of the long-play","breadcrumb":{"@id":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/#breadcrumb"}},{"@type":"BreadcrumbList","@id":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.youredm.com/","url":"https://www.youredm.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.youredm.com/news/","url":"https://www.youredm.com/news/","name":"EDM News"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/","url":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/","name":"Your EDM&#8217;s Top 10 Albums Of 2019"}}]},{"@type":"Article","@id":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/#article","isPartOf":{"@id":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/#webpage"},"author":{"@id":"https://www.youredm.com/#/schema/person/868a10f5bfa0995ccac690a7c2441bb8"},"headline":"Your EDM&#8217;s Top 10 Albums Of 2019","datePublished":"2019-12-23T20:45:58+00:00","dateModified":"2019-12-23T21:00:00+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/#webpage"},"publisher":{"@id":"https://www.youredm.com/#organization"},"image":{"@id":"https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/#primaryimage"},"keywords":"2019,avicii,Big Wild,delta heavy,dj snake,Flume,Fox Stevenson,ILLENIUM,karma fields,list,madeon,sebastian,top 10 albums,top 10 albums 2019","articleSection":"EDM News"},{"@type":["Person"],"@id":"https://www.youredm.com/#/schema/person/868a10f5bfa0995ccac690a7c2441bb8","name":"Matthew Meadow","image":{"@type":"ImageObject","@id":"https://www.youredm.com/#authorlogo","url":"https://secure.gravatar.com/avatar/6f90a277d315089b3372f50c8d1a818f?s=96&d=mm&r=x","caption":"Matthew Meadow"},"description":"Lover of all bass music. I'm not afraid to speak my mind and put it to paper, and I do it often. I call Los Angeles my home, there's no better place for emerging EDM. Get in touch with me more via email or Twitter.","sameAs":["https://www.facebook.com/matcheeew","https://www.instagram.com/matt_meadow_/","https://twitter.com/themattmeadow"]}]}</script>

<link rel="amphtml" href="https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/amp/" /><meta name="generator" content="AMP for WP 0.9.98.14" /><link rel='dns-prefetch' href='//www.youredm.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Your EDM &raquo; Feed" href="https://www.youredm.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Your EDM &raquo; Comments Feed" href="https://www.youredm.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Your EDM &raquo; Your EDM&#8217;s Top 10 Albums Of 2019 Comments Feed" href="https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.youredm.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.13"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='vuukle-widget-css' href='https://www.youredm.com/wp-content/plugins/free-comments-for-wordpress-vuukle/widget.css?ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.youredm.com/wp-includes/css/dashicons.min.css?ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-lazyloadxt-fadein-css-css' href='//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/css/jquery.lazyloadxt.fadein.css?ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='a3a3_lazy_load-css' href='//www.youredm.com/wp-content/uploads/sass/a3_lazy_load.min.css?ver=1498038417' type='text/css' media='all' />
<link rel='stylesheet' id='cb-main-stylesheet-css' href='https://www.youredm.com/wp-content/themes/revfour/library/css/style.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='cb-font-stylesheet-css' href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700%7COpen+Sans%3A400%2C700%2C400italic&#038;ver=1.2.1' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='cb-ie-only-css'  href='https://www.youredm.com/wp-content/themes/revfour/library/css/ie.css?ver=1.2.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='fontawesome-css' href='https://www.youredm.com/wp-content/themes/revfour/library/css/font-awesome-4.3.0/css/font-awesome.min.css?ver=4.3.0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var param = {"vuukle_version":"2.44","api_key":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.youredm.com/wp-content/plugins/free-comments-for-wordpress-vuukle/widget.js?ver=4.9.13'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-content/themes/revfour/library/js/modernizr.custom.min.js?ver=2.6.2'></script>
<link rel='https://api.w.org/' href='https://www.youredm.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.youredm.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.youredm.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.13" />
<link rel='shortlink' href='https://www.youredm.com/?p=253079' />
<link rel="alternate" type="application/json+oembed" href="https://www.youredm.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.youredm.com%2F2019%2F12%2F23%2Fyour-edms-top-10-albums-of-2019%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.youredm.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.youredm.com%2F2019%2F12%2F23%2Fyour-edms-top-10-albums-of-2019%2F&#038;format=xml" />
<link rel="dns-prefetch" href="https://cdn.vuukle.com/">
<link rel="dns-prefetch" href="https://api.vuukle.com/">
<link rel="dns-prefetch" href="https://vuukle.com/">
<meta property="fb:pages" content="240577849383245">

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "21854097" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=21854097&cv=2.0&cj=1" />
</noscript>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-31605441-1', 'auto');
  ga('send', 'pageview');
ga('set', 'anonymizeIp', true);

</script>

<style type="text/css">.cb-post-views {
    display:none;
}
body img {
    line-height: 0;
    font-size: 0;
}

#adBottom {
    display: none;
}

@media only screen and (min-width: 310px) and (max-width:500px) {
    #adBottom {
        display: block;
        left:0;
        position: fixed;
        text-align:center;
        bottom: 0px;
        width:100%;
        z-index:999;
        background-color: #eee;
        max-height: 50px;
    }
} .cb-stuck #cb-nav-bar .cb-main-nav #cb-nav-logo, #cb-nav-bar .cb-main-nav #cb-nav-logo img { width: 133px; }#cb-nav-bar .cb-mega-menu-columns .cb-sub-menu > li > a { color: #1e73be; }</style><style type="text/css">body, #respond, .cb-font-body { font-family: 'Open Sans', sans-serif; } h1, h2, h3, h4, h5, h6, .cb-font-header, #bbp-user-navigation, .cb-byline{ font-family:'Montserrat', sans-serif; }</style><style>.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-122622:hover, .cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-122622:focus { background:# !important ; }
.cb-mm-on #cb-nav-bar .cb-main-nav .menu-item-122622 .cb-big-menu { border-top-color: #; }</style> 

<meta name="p:domain_verify" content="0c5d685bf620f9c2765a00efa160956d" />
<meta name="google-site-verification" content="S3usKI5Zz4p0v87c9TZuCFdQxdPs_JaM11RJMkKp9PY" />



<script data-cfasync="false" type="text/javascript">
  var freestar = freestar || {};
  freestar.hitTime = Date.now();
  freestar.queue = freestar.queue || [];
  freestar.config = freestar.config || {};
  freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;

  // Tag IDs set here, must match Tags served in the Body for proper setup
  freestar.config.enabled_slots = [
    "youredm_728x90_320x50_top",
    "youredm_970x250_970x90_728x90_ATF",
    "youredm_300x600_300x250_320x100_320x50_mob_btf",
    "youredm_300x250_320x50_320x100_right_1",
    "youredm_300x1050_300x600_300x250_right_2",
    "youredm_300x250_320x50_320x100_right_3",
    "youredm_300x1050_300x600_300x250_right_4",
	"youredm_1x1_skin",
    "youredm_728x90_300x250_incontent_1",
// 	  "youredm-video-desktop-infeed-1",
// 	  "youredm-video-mobile-infeed-1"
  ];

  !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/youredm-com";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
</script>


<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '270428839820698'); // Insert your pixel ID here.
fbq('track', 'PageView');
fbq('track', 'ViewContent');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=270428839820698&ev=PageView&noscript=1"
/></noscript>



<meta property="fb:pages" content="240577849383245" />

</head>
<body class="post-template-default single single-post postid-253079 single-format-standard  cb-sidebar-right cb-sticky-mm cb-nav-logo-on cb-logo-nav-sticky cb-tm-light cb-body-light cb-menu-light cb-mm-dark cb-footer-dark cb-m-logo-off cb-m-sticky cb-sw-tm-fw cb-sw-header-fw cb-sw-menu-fw cb-sw-footer-fw cb-fis-b-standard-uncrop cb-mob-only cb-bg-to-on">
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=366355696827687";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<div align="center" id="youredm_1x1_skin">
<script data-cfasync="false" type="text/javascript">
    freestar.queue.push(function () { googletag.display('youredm_1x1_skin'); });
</script>
</div>


<div id="cb-outer-container" style="margin-top:0px;">
<div id="cb-top-menu" class="clearfix cb-font-header ">
<div class="wrap clearfix cb-site-padding cb-top-menu-wrap">
<div class="cb-left-side cb-mob">
<a href="#" id="cb-mob-open" class="cb-link"><i class="fa fa-bars"></i></a>
</div>
</div>
</div>
<div id="cb-mob-menu">
<a href="#" id="cb-mob-close" class="cb-link"><i class="fa cb-times"></i></a>
<div class="cb-mob-menu-wrap">
<ul class="cb-mobile-nav cb-top-nav"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-122622"><a href="https://www.youredm.com/news/">EDM News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-122630"><a href="https://www.youredm.com/featured/">Featured</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122631"><a href="https://www.youredm.com/master-editorial/">Editorials</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122633"><a href="https://www.youredm.com/master-editorial/giveaways/">Giveaways</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-124688"><a href="https://www.youredm.com/tag/aspire-to-inspire">Aspire To Inspire</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122634"><a href="https://www.youredm.com/master-editorial/industry-spotlight-master-editorial/">Industry Spotlight</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122635"><a href="https://www.youredm.com/master-editorial/interview/">Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122643"><a href="https://www.youredm.com/photos-2/">Event Photos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-122623"><a href="https://www.youredm.com/house/">House</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-228851"><a href="https://www.youredm.com/house/bass-house/">Bass House</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122636"><a href="https://www.youredm.com/house/commercial-house/">Commercial House</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122637"><a href="https://www.youredm.com/house/minimalhouse/">Deep House</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122638"><a href="https://www.youredm.com/house/disco-house/">Disco House</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122639"><a href="https://www.youredm.com/house/dutch-house/">Dutch House</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122640"><a href="https://www.youredm.com/house/electro-house/">Electro House</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122641"><a href="https://www.youredm.com/house/future-house-house/">Future House</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122642"><a href="https://www.youredm.com/house/indie-dance/">Indie Dance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-123086"><a href="https://www.youredm.com/house/nu-disco-house/">Nu-Disco</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122652"><a href="https://www.youredm.com/house/progessive-house/">Progressive House</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122653"><a href="https://www.youredm.com/house/techhouse/">Tech House</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-122624"><a href="https://www.youredm.com/bass-music-2/">Bass Music</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122625"><a href="https://www.youredm.com/bass-music-2/drum-n-bass-2/">Drum n Bass</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122626"><a href="https://www.youredm.com/bass-music-2/dubstep-bass-music-2/">Dubstep</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122627"><a href="https://www.youredm.com/bass-music-2/future-bass/">Future Bass</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122628"><a href="https://www.youredm.com/bass-music-2/glitch-hop-bass-music-2/">Glitch Hop</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122629"><a href="https://www.youredm.com/bass-music-2/hardstyle2/">Hardstyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122650"><a href="https://www.youredm.com/bass-music-2/moombahton-2/">Moombahton</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122651"><a href="https://www.youredm.com/bass-music-2/trap-2/">Trap</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122880"><a href="https://www.youredm.com/free-download/">Free Downloads</a></li>
</ul> </div>
</div>
<div id="cb-container" class="clearfix wrap">
<header id="cb-header" class="cb-header  cb-with-block " role="banner">
<div id="cb-logo-box" class="cb-logo-left wrap">
<div id="logo">
<a href="https://www.youredm.com">
<img src="https://www.youredm.com/wp-content/uploads/2015/04/yedmv3sm.png" alt=" logo" data-at2x="https://www.youredm.com/wp-content/uploads/2015/04/yedmv3sm.png">
</a>
</div>
<div class="cb-large cb-block"><div align="center" id="youredm_728x90_320x50_top">
<script data-cfasync="false" type="text/javascript">
    freestar.queue.push(function () { googletag.display('youredm_728x90_320x50_top'); });
</script>
</div></div> </div>
</header>
<div id="cb-menu-search" class="cb-s-modal cb-modal"><div class="cb-close-m cb-ta-right"><i class="fa cb-times"></i></div><div class="cb-s-modal-inner cb-pre-load cb-light-loader cb-modal-inner cb-font-header cb-mega-three cb-mega-posts clearfix"><form role="search" method="get" class="cb-search" action="https://www.youredm.com/">
<input type="text" class="cb-search-field cb-font-header" placeholder="Search.." value="" name="s" title="" autocomplete="off">
<button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button>
</form><div id="cb-s-results"></div></div></div>
<nav id="cb-nav-bar" class="clearfix " role="navigation">
<div class="cb-nav-bar-wrap cb-site-padding clearfix cb-font-header  cb-menu-fw">
<ul class="cb-main-nav wrap clearfix"><li id="menu-item-122622" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-122622"><a href="https://www.youredm.com/news/">EDM News</a></li>
<li id="menu-item-122630" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-122630"><a href="https://www.youredm.com/featured/">Featured</a><div class="cb-links-menu cb-menu-drop"><ul class="cb-sub-menu cb-sub-bg"> <li id="menu-item-122631" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122631"><a href="https://www.youredm.com/master-editorial/" data-cb-c="8849" class="cb-c-l">Editorials</a></li>
<li id="menu-item-122633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122633"><a href="https://www.youredm.com/master-editorial/giveaways/" data-cb-c="5290" class="cb-c-l">Giveaways</a></li>
<li id="menu-item-124688" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-124688"><a href="https://www.youredm.com/tag/aspire-to-inspire" data-cb-c="124688" class="cb-c-l">Aspire To Inspire</a></li>
<li id="menu-item-122634" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122634"><a href="https://www.youredm.com/master-editorial/industry-spotlight-master-editorial/" data-cb-c="17519" class="cb-c-l">Industry Spotlight</a></li>
<li id="menu-item-122635" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122635"><a href="https://www.youredm.com/master-editorial/interview/" data-cb-c="164" class="cb-c-l">Interviews</a></li>
<li id="menu-item-122643" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122643"><a href="https://www.youredm.com/photos-2/" data-cb-c="10407" class="cb-c-l">Event Photos</a></li>
</ul></div></li>
<li id="menu-item-122623" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-122623"><a href="https://www.youredm.com/house/">House</a><div class="cb-links-menu cb-menu-drop"><ul class="cb-sub-menu cb-sub-bg"> <li id="menu-item-228851" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-228851"><a href="https://www.youredm.com/house/bass-house/" data-cb-c="22106" class="cb-c-l">Bass House</a></li>
<li id="menu-item-122636" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122636"><a href="https://www.youredm.com/house/commercial-house/" data-cb-c="59" class="cb-c-l">Commercial House</a></li>
<li id="menu-item-122637" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122637"><a href="https://www.youredm.com/house/minimalhouse/" data-cb-c="317" class="cb-c-l">Deep House</a></li>
<li id="menu-item-122638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122638"><a href="https://www.youredm.com/house/disco-house/" data-cb-c="60" class="cb-c-l">Disco House</a></li>
<li id="menu-item-122639" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122639"><a href="https://www.youredm.com/house/dutch-house/" data-cb-c="281" class="cb-c-l">Dutch House</a></li>
<li id="menu-item-122640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122640"><a href="https://www.youredm.com/house/electro-house/" data-cb-c="31" class="cb-c-l">Electro House</a></li>
<li id="menu-item-122641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122641"><a href="https://www.youredm.com/house/future-house-house/" data-cb-c="17950" class="cb-c-l">Future House</a></li>
<li id="menu-item-122642" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122642"><a href="https://www.youredm.com/house/indie-dance/" data-cb-c="4891" class="cb-c-l">Indie Dance</a></li>
<li id="menu-item-123086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-123086"><a href="https://www.youredm.com/house/nu-disco-house/" data-cb-c="13391" class="cb-c-l">Nu-Disco</a></li>
<li id="menu-item-122652" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122652"><a href="https://www.youredm.com/house/progessive-house/" data-cb-c="30" class="cb-c-l">Progressive House</a></li>
<li id="menu-item-122653" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122653"><a href="https://www.youredm.com/house/techhouse/" data-cb-c="316" class="cb-c-l">Tech House</a></li>
</ul></div></li>
<li id="menu-item-122624" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children cb-has-children menu-item-122624"><a href="https://www.youredm.com/bass-music-2/">Bass Music</a><div class="cb-links-menu cb-menu-drop"><ul class="cb-sub-menu cb-sub-bg"> <li id="menu-item-122625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122625"><a href="https://www.youredm.com/bass-music-2/drum-n-bass-2/" data-cb-c="1344" class="cb-c-l">Drum n Bass</a></li>
<li id="menu-item-122626" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122626"><a href="https://www.youredm.com/bass-music-2/dubstep-bass-music-2/" data-cb-c="1959" class="cb-c-l">Dubstep</a></li>
<li id="menu-item-122627" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122627"><a href="https://www.youredm.com/bass-music-2/future-bass/" data-cb-c="8276" class="cb-c-l">Future Bass</a></li>
<li id="menu-item-122628" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122628"><a href="https://www.youredm.com/bass-music-2/glitch-hop-bass-music-2/" data-cb-c="5453" class="cb-c-l">Glitch Hop</a></li>
<li id="menu-item-122629" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122629"><a href="https://www.youredm.com/bass-music-2/hardstyle2/" data-cb-c="13462" class="cb-c-l">Hardstyle</a></li>
<li id="menu-item-122650" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122650"><a href="https://www.youredm.com/bass-music-2/moombahton-2/" data-cb-c="830" class="cb-c-l">Moombahton</a></li>
<li id="menu-item-122651" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122651"><a href="https://www.youredm.com/bass-music-2/trap-2/" data-cb-c="1889" class="cb-c-l">Trap</a></li>
</ul></div></li>
<li id="menu-item-122880" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122880"><a href="https://www.youredm.com/free-download/">Free Downloads</a></li>
<li id="cb-nav-logo" class="cb-logo-nav-sticky-type" style="padding-top: 5px"><a href="https://www.youredm.com"><img src="https://www.youredm.com/wp-content/uploads/2015/04/yedmv3sm.png" alt="site logo" data-at2x="https://www.youredm.com/wp-content/uploads/2015/04/yedmv3sm.png"></a></li></ul> </div>
</nav>

<div align="center" id="youredm_970x250_970x90_728x90_ATF">
<script data-cfasync="false" type="text/javascript">
    freestar.queue.push(function () { googletag.display('youredm_970x250_970x90_728x90_ATF'); });
</script>
</div>

<div id="cb-content" class="wrap clearfix">
<div id="main" class="cb-main" role="main">
<div class="cb-breadcrumbs"><a href="https://www.youredm.com">Home</a><i class="fa fa-angle-right"></i><div itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.youredm.com/news/" title="View all posts in EDM News" itemprop="url"><span itemprop="title">EDM News</span></a></div></div>
<article id="post-253079" class="clearfix post-253079 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-34353 tag-avicii tag-big-wild tag-delta-heavy tag-dj-snake tag-flume tag-fox-stevenson tag-illenium tag-karma-fields tag-list tag-madeon tag-sebastian tag-top-10-albums tag-top-10-albums-2019" role="article">
<div id="cb-featured-image" class="cb-fis cb-fis-block-standard"><div class="cb-mask"><img width="2048" height="1365" src="https://www.youredm.com/wp-content/uploads/2019/11/Madeon_Amsterdam_Sebdevinc-6.jpg" class="attachment-cb-full-full size-cb-full-full wp-post-image" alt="madeon" srcset="https://www.youredm.com/wp-content/uploads/2019/11/Madeon_Amsterdam_Sebdevinc-6.jpg 2048w, https://www.youredm.com/wp-content/uploads/2019/11/Madeon_Amsterdam_Sebdevinc-6-768x512.jpg 768w, https://www.youredm.com/wp-content/uploads/2019/11/Madeon_Amsterdam_Sebdevinc-6-1024x683.jpg 1024w, https://www.youredm.com/wp-content/uploads/2019/11/Madeon_Amsterdam_Sebdevinc-6-360x240.jpg 360w" sizes="(max-width: 2048px) 100vw, 2048px" /></div><div class="cb-entry-header cb-meta clearfix"><h1 class="entry-title cb-entry-title cb-title" itemprop="headline">Your EDM&#8217;s Top 10 Albums Of 2019</h1><div class="cb-byline"><span class="cb-author"> <a href="https://www.youredm.com/author/matt-meadow/">Matthew Meadow</a></span><span class="cb-separator"><i class="fa fa-times"></i></span><span class="cb-date"><time class="updated" datetime="2019-12-23">December 23, 2019</time></span></div><div class="cb-post-meta"><span class="cb-category cb-element"><a href="https://www.youredm.com/news/" title="View all posts in EDM News">EDM News</a></span></div></div></div>
<section class="cb-entry-content clearfix">
<div id="vuukle-powerbar" class="vuukle-powerbar powerbarBoxDiv" style=" " data-styles=""></div>
<p>These past few years, at least since Your EDM has been keeping track of <strong>Top 10 Albums</strong> of the year, have been a phenomenal resurgence of the long-play format for dance music. It&#8217;s not even that albums weren&#8217;t a thing before 2014 or 2015, but their frequency was certainly less so than now. It seems that every week some artist has a new album coming out.</p><script async src="https://d2szg1g41jt3pq.cloudfront.net/"></script><center style="line-height: 0px;"><div id="feature_unit" align="center"><div id="ffm_widget"></div><script>window.featureFM_PassBack = function () { }; window.featureFM = function (e, t, n) { var r, a, i = e.getElementsByTagName(t)[0]; if (!e.getElementById(n)) return a = e.createElement(t), a.id = n, a.src = "//cdn.feature.fm/widgets/init.js", i.parentNode.insertBefore(a, i), window.featureFM || (r = { _e: [], ready: function (e) { r._e.push(e) } }) }(document, "script", "featurefm-widgets"), featureFM_renderWidget = function (e) { function t(t) { if (e.debug_mode) try { console.log(t) } catch (n) { } finally { return } } featureFM.api.setApiKey(e.api_key), featureFM.api.registerNewConsumer(null, null, null, function (n, r) { if (n) return void t("Feature.fm - Could not register a consumer, please contactfeature.fm support"); try { featureFM.api.setConsumer(r.consumer_token), featureFM.api.showWebWidget(e.container_id, e.layout, e.placement, e.keywords, e.passback, e.restrictedPlatform == "mobile" ? true : false, e.restrictedPlatform == "web" ? true : false) } catch (a) { t(a) } finally { return } }) }, featureFM.ready = function () { featureFM_renderWidget({ api_key: "7e8cec1a60df4e2a89c7481071273550", container_id: "ffm_widget", placement: "mobile", layout: "grid", keywords: ["edm", "electronica/dance", "youredm.com"], debug_mode: false, passback: featureFM_PassBack, restrictedPlatform: "mobile" }) };</script></div><br /><div align="center" id="youredm_728x90_300x250_incontent_1"><script data-cfasync="false" type="text/javascript">freestar.queue.push(function () { googletag.display("youredm_728x90_300x250_incontent_1"); });</script></div></center>
<p>A lot of that has to do with just <em>how many</em> artists there are now, with more coming out of the woodwork every day. A lot of it also has to do with the rise in streaming and the accessibility of music. And some of it just has to do with artists having more to say and communicate through their art. No matter the reason, as listeners, we&#8217;re blessed to have so many unique and engaging artist projects to enjoy.</p>
<p>This year, there were easily over 100 albums released that were either deeply embedded in the dance music world or adjacent to it. Debut albums, second albums, first albums in over five, six, seven years, you name it, it was put out this year. Narrowing the list down to just ten that were exemplary beyond all the rest is never an easy task, but it&#8217;s a challenge we enjoy. Not everyone will agree with these choices, but without a doubt, these are ten albums that truly made a mark on 2019 and will continue to be played years from now.</p>
<h4>10. Avicii &#8211; TIM</h4>
<p><em>Listening to TIM with that mindset is tragically bittersweet. After all, it&#8217;s always easy to implant your own interpretations on an artist&#8217;s music after they&#8217;ve passed, especially if they&#8217;ve taken their own life. (Think Chester Bennington&#8217;s music with Linkin Park.) That being said, much of TIM is incredibly bright and hopeful with uplifting melodies and powerful writing.</em></p>
<p><iframe src="https://open.spotify.com/embed/album/6Ad1E9vl75ZB3Ir87zwXIJ" width="400" height="380" frameborder="0"></iframe></p>
<h4>9. Karma Fields &#8211; Body Rush</h4>
<p><em>Spanning 14 tracks, BODY RUSH is a sultry, smooth, and energetic album that calls upon influences from James Blake, ZHU, and more. The result is a diverse and powerful album that plays on all the strengths of Karma Fields while continuing to push the boundaries of what that brand means. Only four tracks from the album were previously released as singles, leaving fans ten fresh and brilliant tracks to listen to for the first time.</em></p>
<p><iframe src="https://open.spotify.com/embed/album/3crwiuhELEdgE76jNhjeCg" width="400" height="380" frameborder="0"></iframe></p>
<h4>8. DJ Snake &#8211; Carte Blanche</h4>
<p><em>Carte Blanche is a sizzling collection of seventeen tracks, including previously released singles &#8220;Taki Taki&#8221; and &#8220;Enzo,&#8221; which, between just the two of them, count Sheck Wes, Offset, 21 Savage, Gucci Mane, Selena Gomez, Ozuna, and Cardi B as collaborators. Other guest appearances on the album include Zomboy, Majid Jordan, Zhu, Tchami, Malaa, Mercer, Bryson Tiller, J Balvin, Tyga, Sean Paul, Eptic, Burna Boy, Gashi, and more. To break it down math-style, there is an average of 1.35 collaborators per track on the album.</em></p>
<p><iframe src="https://open.spotify.com/embed/album/2MFS6WG6jnPAgvJpV3PehR" width="400" height="380" frameborder="0"></iframe></p>
<h4>7. Delta Heavy &#8211; Only In Dreams</h4>
<p><em>Delta Heavy manages to evolve and grow beyond their first album by leaps and bounds, keeping hold of their raw and pure sound, all while pushing it further. The rock and melodic elements incorporated in Only In Dreams, like in &#8220;Here With Me&#8221; and &#8220;Show Me The Light,&#8221; demonstrate an observable growth as artists that&#8217;s truly wonderful to see.</em></p>
<p><iframe src="https://open.spotify.com/embed/album/0VlXHVcQTaih2dSWJ02wR5" width="400" height="380" frameborder="0"></iframe></p>
<h4>6. Big Wild &#8211; Superdream</h4>
<p><em>Now, Big Wild has taken the next step in his musical evolution, having released his debut album, Superdream, on Counter Records. Not only has the album racked up over nine million streams on Spotify alone, he took Big Wild on the road for a solo headlining tour, playing to sold out crowds across the country.</em></p>
<p><iframe src="https://open.spotify.com/embed/album/7LZAgsQQr0cm61SmUdgKlz" width="400" height="380" frameborder="0"></iframe></p>
<h4>5. Illenium &#8211; Ascend</h4>
<p><em>There&#8217;s no two ways around it &#8212; Ascend is a fucking brilliant body of work. This is by far Illenium&#8217;s greatest album and his most daring endeavor as an artist. Jumping from 12 tracks on his debut album Ashes to 13 on his second album Awake, and then 17 on Ascend is indicative of just how much of a story Illenium has to tell.</em></p>
<p><iframe src="https://open.spotify.com/embed/album/60xcVwuQJAOyu11xf9mObS" width="400" height="380" frameborder="0"></iframe></p>
<h4>4. SebastiAn &#8211; Thirst</h4>
<p><em>8 years after his last album, Total, SebastiAn decided to grace the world with his new album Thirst &#8212; and ironically, it quenched exactly what the title described. This album is wildly satisfying in ways that on Ed Banger can supply. With a uniquely French touch, SebastiAn manages to fly through genres and influences in a way that tells a narrative rather than just putting one track after another. From the first &#8220;BWOOOOOOOM&#8221; of the opening track, &#8220;Thirst,&#8221; the album sets the tone for the remaining hour and four minutes. And what an enthralling hour it is.</em></p>
<p><iframe src="https://open.spotify.com/embed/album/7AoXn0h3P8wtRN36CrA14y" width="400" height="380" frameborder="0"></iframe></p>
<h4>3. Fox Stevenson &#8211; Killjoy</h4>
<p><em>It&#8217;s hard to think of another album without any features that has had so much of a true album vibe. Pioneers like Robert Delong and Big Data come to mind, but no one so firmly rooted in the EDM world as Fox. With his brilliant combination of pop lyrics and melodies with drum n bass tempos, this is by far one of the most unparalleled listening experiences of the year.</em></p>
<p><iframe src="https://open.spotify.com/embed/album/3QqchF6lxDCfjLBm3zfGsE" width="400" height="380" frameborder="0"></iframe></p>
<h4>2. Flume &#8211; Hi This Is Flume</h4>
<p><em>From front to back, he is unapologetically himself throughout this entire mixtape. Odd canters and off-beat patterns revolve throughout the atmosphere and justly applied vocals fill the void in between, providing just enough backing for the pulsating rhythms strewn almost carelessly between tracks. I say carelessly, but it&#8217;s truly a careless perfection. Like the artist he is, it feels like Flume threw paint at the wall and it just happened to turned out flawless.</em></p>
<p><iframe src="https://open.spotify.com/embed/album/2Vx9FC6Um8i6kEtY7HNswB" width="400" height="380" frameborder="0"></iframe></p>
<h4>1. Madeon &#8211; Good Faith</h4>
<p><em>The 35-minute album is truly a holy experience. The title Good Faith is actually frighteningly apropos as many of the tracks exude a combination of gospel influence and French house stylings. But the album isn&#8217;t religious in that sense, it&#8217;s more &#8220;spiritual&#8221; as Madeon himself would put it.</em></p>
<p><iframe src="https://open.spotify.com/embed/album/6Lq1lrCfkpxKa4jCo5gKWr" width="400" height="380" frameborder="0"></iframe></p>
<div id="vuukle-emote" style='max-width:600px' class="emotesBoxDiv"></div></p>
<div id="respond"></div>

<script>
      var wb = window.wb || (window.wb = {});
      wb.q || (wb.q = []);
      wb.q.push(['addGrid', {siteId: '113574', id : "wb-ad-grid"}])
      </script>
<script async src='https://d2ltxycs9nfmuc.cloudfront.net/'></script>
<div id="wb-ad-grid"></div>

<div id="vuukle-comments" class="commentBoxDiv"></div>
<script>
	var VUUKLE_CONFIG = {
		apiKey: "76d56219-8030-4aae-a36e-0791be6ae9bb",
		articleId: "253079",
		tags: "2019, avicii, Big Wild",
		author: "Matthew Meadow",
                        
		// Lang

				// Articles - recommendations in emotes and comments widget
		recommendationsWideImages: false,
				recommendationsProtocol: "",
				globalRecommendations: false,
		// Colors
		darkMode: false,
		// By Widget
                theme: {color: "108ee9"},
		comments: {
			vuukleAuth: true,
			hideRecommendedArticles: false,
			hideCommentInputBox: false,
			enabled: true,
			commentingClosed: false,
			maxChars: '3000',
			countToLoad: '5',
			toxicityLimit: '80',
			spamLimit: '90',
			sorting: 'latest',
			transliteration:{
				language: 'en',
				enabledByDefault: false,
			},
			customText: {
				recommendedStories: 'TALK OF THE TOWN',
			},
		},
		emotes: {
			enabled: 1,
			hideRecommendedArticles: false,
			size: '70', // icons size
			firstImg: '',
			firstName: 'HAPPY',
			secondImg: '',
			secondName: 'INDIFFERENT',
			thirdImg: '',
			thirdName: 'AMUSED',
			fourthImg: '',
			fourthName: 'EXCITED',
			fifthImg: '',
			fifthName:'ANGRY',
			sixthImg: '',
			sixthName: 'SAD',
			disable: [],
			customText: {},
		},
		powerbar: {
			enabled: true,
			defaultEmote: 1,
			customUrls: {
				facebook: '',
				google: '',
				twitter: '',
				linkedin: '',
			},
			customText: {},

			items: [
							],
		},

	};
	(function () {
		var d = document,
		s = d.createElement('script');
		s.async = true;
		s.src = 'https://cdn.vuukle.com/platform.js';
		(d.head || d.body).appendChild(s);
	})();
</script> 
<div align="center" id="youredm_300x600_300x250_320x100_320x50_mob_btf">
<script data-cfasync="false" type="text/javascript">
    freestar.queue.push(function () { googletag.display('youredm_300x600_300x250_320x100_320x50_mob_btf'); });
</script>
</div>

</section> 
<footer class="cb-article-footer">
<p class="cb-tags cb-post-footer-block"> <a href="https://www.youredm.com/tag/2019/" rel="tag">2019</a><a href="https://www.youredm.com/tag/avicii/" rel="tag">avicii</a><a href="https://www.youredm.com/tag/big-wild/" rel="tag">Big Wild</a><a href="https://www.youredm.com/tag/delta-heavy/" rel="tag">delta heavy</a><a href="https://www.youredm.com/tag/dj-snake/" rel="tag">dj snake</a><a href="https://www.youredm.com/tag/flume/" rel="tag">Flume</a><a href="https://www.youredm.com/tag/fox-stevenson/" rel="tag">Fox Stevenson</a><a href="https://www.youredm.com/tag/illenium/" rel="tag">ILLENIUM</a><a href="https://www.youredm.com/tag/karma-fields/" rel="tag">karma fields</a><a href="https://www.youredm.com/tag/list/" rel="tag">list</a><a href="https://www.youredm.com/tag/madeon/" rel="tag">madeon</a><a href="https://www.youredm.com/tag/sebastian/" rel="tag">sebastian</a><a href="https://www.youredm.com/tag/top-10-albums/" rel="tag">top 10 albums</a><a href="https://www.youredm.com/tag/top-10-albums-2019/" rel="tag">top 10 albums 2019</a></p>

<div id="vicevideo"></div>
<div class="cb-social-sharing cb-post-block-bg cb-post-footer-block cb-on clearfix"><div class="cb-title cb-font-header">Share On</div><div class="cb-sharing-buttons"><div id="fb-root"></div> <script>(function(d, s, id) {var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0"; fjs.parentNode.insertBefore(js, fjs); }(document, "script", "facebook-jssdk"));</script><div class="cb-facebook cb-sharing-button"><div class="fb-share-button" data-href="https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/" data-layout="button_count"></div></div><div class="cb-facebook cb-sharing-button"><div class="fb-like" data-href="https://www.youredm.com/2019/12/23/your-edms-top-10-albums-of-2019/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div></div><div class="cb-google cb-sharing-button "> <div class="g-plusone" data-size="medium"></div> <script type="text/javascript"> (function() {var po = document.createElement("script"); po.type = "text/javascript"; po.async = true; po.src = "https://apis.google.com/js/plusone.js"; var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(po, s); })(); </script></div><div class="cb-twitter cb-sharing-button"><a href="https://twitter.com/share" class="twitter-share-button" data-dnt="true" data-count="horizontal">Tweet</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?"http":"https";if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document, "script", "twitter-wjs");</script></div></div></div><div id="cb-next-previous-posts" class="cb-next-previous cb-post-block-bg cb-underline-h cb-post-footer-block cb-font-header clearfix"><div class="cb-previous-post cb-meta cb-next-previous-block"><div class="cb-arrow"><i class="fa fa-angle-left"></i></div><span class="cb-read-previous-title cb-read-title"><a href="https://www.youredm.com/2019/12/23/zeds-dead-rezz-collab-watch/">Previous Article</a></span><a href="https://www.youredm.com/2019/12/23/zeds-dead-rezz-collab-watch/" class="cb-previous-title cb-title">Zeds Dead Drop Insane Rezz Collab During Live Show [MUST WATCH]</a></div><div class="cb-next-post cb-meta cb-next-previous-block"><div class="cb-arrow"><i class="fa fa-angle-right"></i></div><span class="cb-read-next-title cb-read-title"><a href="https://www.youredm.com/2019/12/23/steve-aoki-david-guetta-mdl-beast-festival/">Next Article</a></span><a href="https://www.youredm.com/2019/12/23/steve-aoki-david-guetta-mdl-beast-festival/" class="cb-next-title cb-title">David Guetta & Steve Aoki Go B2B For First Time Ever At MDL Beast Festival [WATCH]</a></div></div><div id="cb-author-box" class="cb-post-footer-block cb-post-block-bg clearfix"><div class="cb-mask"><a href="https://www.youredm.com/author/matt-meadow/"><img alt='' src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src='https://secure.gravatar.com/avatar/6f90a277d315089b3372f50c8d1a818f?s=100&#038;d=mm&#038;r=x' srcset="" data-srcset='https://secure.gravatar.com/avatar/6f90a277d315089b3372f50c8d1a818f?s=200&#038;d=mm&#038;r=x 2x' class='lazy lazy-hidden avatar avatar-100 photo' height='100' width='100' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/6f90a277d315089b3372f50c8d1a818f?s=100&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/6f90a277d315089b3372f50c8d1a818f?s=200&#038;d=mm&#038;r=x 2x' class='avatar avatar-100 photo' height='100' width='100' /></noscript></a></div><div class="cb-meta"><div class="cb-title cb-font-header vcard" itemprop="author"><a href="https://www.youredm.com/author/matt-meadow/"><span class="fn">Matthew Meadow</span></a></div><div class="cb-author-position cb-font-header">Editor-in-Chief</div><p class="cb-author-bio">Lover of all bass music. I'm not afraid to speak my mind and put it to paper, and I do it often. I call Los Angeles my home, there's no better place for emerging EDM. Get in touch with me more via email or Twitter.</p><div class="cb-author-page-contact"><a href="/cdn-cgi/l/email-protection#3d505c49497d4452484f585950135e5250" class="cb-contact-icon cb-tip-bot" data-cb-tip="Email"><i class="fa fa-envelope-o"></i></a> <a href="//www.twitter.com/themattmeadow" target="_blank" class="cb-contact-icon cb-tip-bot" data-cb-tip="Twitter"><i class="fa fa-twitter"></i></a> <a href="https://www.instagram.com/matt_meadow_/" target="_top" class="cb-contact-icon cb-tip-bot" data-cb-tip="Instagram"><i class="fa fa-instagram"></i></a></div></div></div><div id="belowcontent"></div>
<div id="cb-related-posts-block" class="cb-post-footer-block cb-arrows-tr cb-module-block clearfix"><h3 class="cb-title cb-title-header">Related Posts</h3><div id="cb-related-posts" class="cb-slider-2 cb-slider cb-meta-below"><ul class="slides clearfix"> <li class="cb-style-1 clearfix cb-no-1 post-169506 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-announcement tag-avicii tag-demand tag-final-tour tag-retirement tag-tickets-2 tag-viagogo">
<div class="cb-mask"><a href="https://www.youredm.com/2016/03/30/aviciis-retirement-announcement-see-spike-demand-tickets/"><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2015/12/avicii-live1-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /><noscript><img width="360" height="240" src="https://www.youredm.com/wp-content/uploads/2015/12/avicii-live1-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></noscript></a></div>
<div class="cb-meta">
<h4 class="cb-post-title"><a href="https://www.youredm.com/2016/03/30/aviciis-retirement-announcement-see-spike-demand-tickets/">Avicii&#8217;s Retirement Announcement See Spike In Demand For Tickets</a></h4>
</div>
</li>
<li class="cb-style-1 clearfix cb-no-2 post-179391 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-electro-house category-featured category-house tag-infinitum tag-madeon tag-ninth-parallel tag-opus tag-porter-robinson">
<div class="cb-mask"><a href="https://www.youredm.com/2016/06/24/ninth-parallel-finally-releases-long-awaited-opus-infinitum/"><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2016/06/ninth-parallel-infinitum-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /><noscript><img width="360" height="240" src="https://www.youredm.com/wp-content/uploads/2016/06/ninth-parallel-infinitum-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></noscript></a></div>
<div class="cb-meta">
<h4 class="cb-post-title"><a href="https://www.youredm.com/2016/06/24/ninth-parallel-finally-releases-long-awaited-opus-infinitum/">Ninth Parallel Finally Releases Long Awaited Opus, &#8220;Infinitum&#8221;</a></h4>
</div>
</li>
<li class="cb-style-1 clearfix cb-no-1 post-240011 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-events category-featured category-lineup tag-34353 tag-buku-festival tag-dog-blood tag-excision tag-lineup tag-new-orleans">
<div class="cb-mask"><a href="https://www.youredm.com/2018/12/06/dog-blood-return-on-buku-music-arts-project-2019-lineup/"><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2017/08/dog-blood-hard-summer-2017-oh-dag-yo-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="dog blood" srcset="" data-srcset="https://www.youredm.com/wp-content/uploads/2017/08/dog-blood-hard-summer-2017-oh-dag-yo-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2017/08/dog-blood-hard-summer-2017-oh-dag-yo-768x512.jpg 768w, https://www.youredm.com/wp-content/uploads/2017/08/dog-blood-hard-summer-2017-oh-dag-yo-1024x683.jpg 1024w" sizes="(max-width: 360px) 100vw, 360px" /><noscript><img width="360" height="240" src="https://www.youredm.com/wp-content/uploads/2017/08/dog-blood-hard-summer-2017-oh-dag-yo-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="dog blood" srcset="https://www.youredm.com/wp-content/uploads/2017/08/dog-blood-hard-summer-2017-oh-dag-yo-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2017/08/dog-blood-hard-summer-2017-oh-dag-yo-768x512.jpg 768w, https://www.youredm.com/wp-content/uploads/2017/08/dog-blood-hard-summer-2017-oh-dag-yo-1024x683.jpg 1024w" sizes="(max-width: 360px) 100vw, 360px" /></noscript></a></div>
<div class="cb-meta">
<h4 class="cb-post-title"><a href="https://www.youredm.com/2018/12/06/dog-blood-return-on-buku-music-arts-project-2019-lineup/">Dog Blood Return On Buku Music + Arts Project 2019 Lineup</a></h4>
</div>
</li>
<li class="cb-style-1 clearfix cb-no-2 post-233694 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-house category-progessive-house tag-arty tag-avicii tag-bassmnt tag-dedicated tag-for-tim tag-new-song tag-progressive-house">
<div class="cb-mask"><a href="https://www.youredm.com/2018/06/19/arty-new-song-avicii-2/"><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2018/06/ARTY-15-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="arty" srcset="" data-srcset="https://www.youredm.com/wp-content/uploads/2018/06/ARTY-15-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2018/06/ARTY-15-768x510.jpg 768w, https://www.youredm.com/wp-content/uploads/2018/06/ARTY-15-1024x681.jpg 1024w" sizes="(max-width: 360px) 100vw, 360px" /><noscript><img width="360" height="240" src="https://www.youredm.com/wp-content/uploads/2018/06/ARTY-15-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="arty" srcset="https://www.youredm.com/wp-content/uploads/2018/06/ARTY-15-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2018/06/ARTY-15-768x510.jpg 768w, https://www.youredm.com/wp-content/uploads/2018/06/ARTY-15-1024x681.jpg 1024w" sizes="(max-width: 360px) 100vw, 360px" /></noscript></a></div>
<div class="cb-meta">
<h4 class="cb-post-title"><a href="https://www.youredm.com/2018/06/19/arty-new-song-avicii-2/">Arty Debuts New Song &#8220;For Tim&#8221; Dedicated To Avicii</a></h4>
</div>
</li>
<li class="cb-style-1 clearfix cb-no-1 post-169491 post type-post status-publish format-standard has-post-thumbnail hentry category-drum-n-bass-2 category-interview tag-debut-album tag-delta-heavy tag-drum-bass tag-interview-2 tag-paradise-lost tag-ram-records">
<div class="cb-mask"><a href="https://www.youredm.com/2016/03/31/edm-interview-delta-heavy-ram-records/"><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2016/03/1457349778_zu708a-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /><noscript><img width="360" height="240" src="https://www.youredm.com/wp-content/uploads/2016/03/1457349778_zu708a-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></noscript></a></div>
<div class="cb-meta">
<h4 class="cb-post-title"><a href="https://www.youredm.com/2016/03/31/edm-interview-delta-heavy-ram-records/">Your EDM Interview: Delta Heavy [RAM Records]</a></h4>
</div>
 </li>
<li class="cb-style-1 clearfix cb-no-2 post-149061 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-featured tag-avicii tag-dirty-south tag-edm-in-video-games tag-flosstradamus tag-hudson-mohawke tag-kill-the-noise tag-major-lazer tag-need-for-speed tag-need-for-speed-2015 tag-netsky tag-soundtrack tag-spor tag-the-chemical-brothers tag-video-game tag-wolfgang-gartner tag-zeds-dead">
<div class="cb-mask"><a href="https://www.youredm.com/2015/10/14/the-new-need-for-speed-soundtrack-is-catered-to-edm-fans/"><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2015/10/Need-For-Speed-2015-Logo-Art-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="" data-srcset="https://www.youredm.com/wp-content/uploads/2015/10/Need-For-Speed-2015-Logo-Art-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2015/10/Need-For-Speed-2015-Logo-Art-1024x680.jpg 1024w, https://www.youredm.com/wp-content/uploads/2015/10/Need-For-Speed-2015-Logo-Art.jpg 1280w" sizes="(max-width: 360px) 100vw, 360px" /><noscript><img width="360" height="240" src="https://www.youredm.com/wp-content/uploads/2015/10/Need-For-Speed-2015-Logo-Art-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.youredm.com/wp-content/uploads/2015/10/Need-For-Speed-2015-Logo-Art-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2015/10/Need-For-Speed-2015-Logo-Art-1024x680.jpg 1024w, https://www.youredm.com/wp-content/uploads/2015/10/Need-For-Speed-2015-Logo-Art.jpg 1280w" sizes="(max-width: 360px) 100vw, 360px" /></noscript></a></div>
<div class="cb-meta">
<h4 class="cb-post-title"><a href="https://www.youredm.com/2015/10/14/the-new-need-for-speed-soundtrack-is-catered-to-edm-fans/">The New Need For Speed Soundtrack Is Catered To EDM Fans</a></h4>
</div>
</li>
<li class="cb-style-1 clearfix cb-no-1 post-107813 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-future-bass category-indie-dance category-trap-2 tag-deep tag-diplo tag-drnuk tag-flume tag-future tag-louis-futon tag-louis-futon-ep">
<div class="cb-mask"><a href="https://www.youredm.com/2014/12/18/louis-futon-drnuk/"><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2014/12/1655281_732650883486158_8454807977371883528_o-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="" data-srcset="https://www.youredm.com/wp-content/uploads/2014/12/1655281_732650883486158_8454807977371883528_o-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2014/12/1655281_732650883486158_8454807977371883528_o-1024x679.jpg 1024w" sizes="(max-width: 360px) 100vw, 360px" /><noscript><img width="360" height="240" src="https://www.youredm.com/wp-content/uploads/2014/12/1655281_732650883486158_8454807977371883528_o-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" srcset="https://www.youredm.com/wp-content/uploads/2014/12/1655281_732650883486158_8454807977371883528_o-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2014/12/1655281_732650883486158_8454807977371883528_o-1024x679.jpg 1024w" sizes="(max-width: 360px) 100vw, 360px" /></noscript></a></div>
<div class="cb-meta">
<h4 class="cb-post-title"><a href="https://www.youredm.com/2014/12/18/louis-futon-drnuk/">Louis Futon &#8211; DRNUK</a></h4>
</div>
</li>
<li class="cb-style-1 clearfix cb-no-2 post-222110 post type-post status-publish format-standard has-post-thumbnail hentry category-bass-music-2 category-drum-n-bass-2 category-dubstep-bass-music-2 category-interview tag-collaboration tag-delta-heavy tag-dirty-audio tag-holly tag-interview-2 tag-stay">
<div class="cb-mask"><a href="https://www.youredm.com/2017/10/13/delta-heavy-x-dirty-audio-talk-massive-new-collaboration-stay-listen-interview/"><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2017/10/DL4AlvfX4AAFK0y.jpg-large-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /><noscript><img width="360" height="240" src="https://www.youredm.com/wp-content/uploads/2017/10/DL4AlvfX4AAFK0y.jpg-large-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></noscript></a></div>
<div class="cb-meta">
<h4 class="cb-post-title"><a href="https://www.youredm.com/2017/10/13/delta-heavy-x-dirty-audio-talk-massive-new-collaboration-stay-listen-interview/">Delta Heavy x Dirty Audio Talk On Massive New Collaboration &#8220;Stay&#8221; [LISTEN + INTERVIEW]</a></h4>
</div>
</li>
</ul></div></div>  <div itemprop="video" itemscope itemtype="http://schema.org/VideoObject"> <div id="5bf4870705b21a781377710a" class="vdb_player vdb_5bf4870705b21a781377710a57d325e276a6057ba4a05a00"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" src="//delivery.vidible.tv/jsonp/pid=5bf4870705b21a781377710a/57d325e276a6057ba4a05a00.js"></script> </div> </div> 

</footer> 
</article> 
</div> 
<aside class="cb-sidebar clearfix" role="complementary"><div id="search-7" class="cb-sidebar-widget widget_search"><form role="search" method="get" class="cb-search" action="https://www.youredm.com/">
<input type="text" class="cb-search-field cb-font-header" placeholder="Search.." value="" name="s" title="" autocomplete="off">
<button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button>
</form></div><div id="text-42" class="cb-sidebar-widget widget_text"> <div class="textwidget"><div align="center" id="youredm_300x250_320x50_320x100_right_1">
<script data-cfasync="false" type="text/javascript">
    freestar.queue.push(function () { googletag.display('youredm_300x250_320x50_320x100_right_1'); });
</script>
</div></div>
</div><div id="text-47" class="cb-sidebar-widget widget_text"><h3 class="cb-sidebar-widget-title cb-widget-title">Follow Us Online</h3> <div class="textwidget"><div align="center"><a href="https://www.facebook.com/YourEdm" target="_blank"><img class="lazy lazy-hidden" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2015/04/64-facebookblk.png" alt="Stalk Us on Facebook" border="0" width="48" height="48" /><noscript><img src="https://www.youredm.com/wp-content/uploads/2015/04/64-facebookblk.png" alt="Stalk Us on Facebook" border="0" width="48" height="48"/></noscript></a>&nbsp;
<a href="https://twitter.com/YourEDM" target="_blank"><img class="lazy lazy-hidden" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2015/04/64-twitterblk1.png" alt="Follow Us on Twitter" border="0" width="48" height="48" /><noscript><img src="https://www.youredm.com/wp-content/uploads/2015/04/64-twitterblk1.png" alt="Follow Us on Twitter" border="0" width="48" height="48"/></noscript></a>&nbsp;
<a href="https://soundcloud.com/your-edms-collection" target="_blank"><img class="lazy lazy-hidden" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2015/04/64-soundcloudblk.png" alt="Follow Us on Soundcloud" border="0" width="48" height="48" /><noscript><img src="https://www.youredm.com/wp-content/uploads/2015/04/64-soundcloudblk.png" alt="Follow Us on Soundcloud" border="0" width="48" height="48"/></noscript></a>&nbsp;
<a href="https://www.youtube.com/user/YourEDMTV" target="_blank"><img class="lazy lazy-hidden" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2015/04/64-youtubeblk.png" alt="Keep It Old-School on RSS" border="0" width="48" height="48" /><noscript><img src="https://www.youredm.com/wp-content/uploads/2015/04/64-youtubeblk.png" alt="Keep It Old-School on RSS" border="0" width="48" height="48"/></noscript></a>
</div>
</div>
</div><div id="text-43" class="cb-sidebar-widget widget_text"> <div class="textwidget"><div align="center" id="youredm_300x1050_300x600_300x250_right_2">
<script data-cfasync="false" type="text/javascript">
    freestar.queue.push(function () { googletag.display('youredm_300x1050_300x600_300x250_right_2'); });
</script>
</div></div>
</div><div id="cb-recent-posts-slider-2" class="cb-sidebar-widget widget-latest-articles-slider"><h3 class="cb-sidebar-widget-title cb-widget-title">Latest Articles</h3> <div class="cb-slider cb-slider-1 cb-recent-slider cb-relative cb-arrows-tr clearfix">
<ul class="slides">
<li class="cb-article cb-style-1 clearfix post-253126 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-for-the-lulz tag-damages tag-dennys tag-donation tag-gofundme tag-green-day tag-punk-rock tag-skrillex tag-wacko">
<div class="cb-mask"><a href="https://www.youredm.com/2019/12/23/damages-at-dennys-punk-show-all-covered-by-green-day/"><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="denny&#039;s" srcset="" data-srcset="https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot-768x512.jpg 768w, https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot.jpg 980w" sizes="(max-width: 360px) 100vw, 360px" /><noscript><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="denny&#039;s" srcset="" data-srcset="https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot-768x512.jpg 768w, https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot.jpg 980w" sizes="(max-width: 360px) 100vw, 360px" /><noscript><img width="360" height="240" src="https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="denny&#039;s" srcset="https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot-360x240.jpg 360w, https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot-768x512.jpg 768w, https://www.youredm.com/wp-content/uploads/2019/12/dennys-restaurant-damaged-from-hardcore-show-in-california-video-screenshot.jpg 980w" sizes="(max-width: 360px) 100vw, 360px" /></noscript></noscript></a></div>
<div class="cb-meta">
<h4 class="cb-post-title"><a href="https://www.youredm.com/2019/12/23/damages-at-dennys-punk-show-all-covered-by-green-day/">Damages At Denny&#8217;s Punk Show All Covered By Green Day</a></h4>
</div>
</li>
<li class="cb-article cb-style-1 clearfix post-253144 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-cdjs tag-dominican-republic tag-misconduct tag-mixer tag-nic-fanciulli tag-rip tag-stage">
<div class="cb-mask"><a href="https://www.youredm.com/2019/12/23/random-man-gets-up-on-dj-booth-and-rips-the-mixer-away-from-decks-video/"><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2016/01/cdjs-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /><noscript><img width="360" height="240" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2016/01/cdjs-360x240.jpg" class="lazy lazy-hidden attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /><noscript><img width="360" height="240" src="https://www.youredm.com/wp-content/uploads/2016/01/cdjs-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" /></noscript></noscript></a></div>
<div class="cb-meta">
<h4 class="cb-post-title"><a href="https://www.youredm.com/2019/12/23/random-man-gets-up-on-dj-booth-and-rips-the-mixer-away-from-decks-video/">Random Man Gets Up On DJ Booth And Rips The Mixer Away From Decks [VIDEO]</a></h4>
</div>
</li>
</ul>
</div>
</div><div id="text-44" class="cb-sidebar-widget widget_text"> <div class="textwidget"><div align="center" id="youredm_300x250_320x50_320x100_right_3">
<script data-cfasync="false" type="text/javascript">
    freestar.queue.push(function () { googletag.display('youredm_300x250_320x50_320x100_right_3'); });
</script>
</div>
<br />
<div align="center" id="youredm_300x1050_300x600_300x250_right_4">
<script data-cfasync="false" type="text/javascript">
    freestar.queue.push(function () { googletag.display('youredm_300x1050_300x600_300x250_right_4'); });
</script>
</div>
</div>
</div></aside>
</div> 
</div> 
<footer id="cb-footer" role="contentinfo">
<div id="cb-widgets" class="cb-footer-x cb-footer-a wrap clearfix cb-site-padding">
<div class="cb-one cb-column clearfix">
<div id="text-46" class="cb-footer-widget clearfix widget_text"><h3 class="cb-footer-widget-title cb-widget-title">Follow Us Online</h3> <div class="textwidget"><div align="center"><a href="https://www.facebook.com/YourEdm" target="_blank"><img class="lazy lazy-hidden" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2015/04/64-facebook.png" alt="Stalk Us on Facebook" border="0" /><noscript><img src="https://www.youredm.com/wp-content/uploads/2015/04/64-facebook.png" alt="Stalk Us on Facebook" border="0"/></noscript></a>&nbsp;
<a href="https://twitter.com/YourEDM" target="_blank"><img class="lazy lazy-hidden" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2015/04/64-twitter1.png" alt="Follow Us on Twitter" border="0" /><noscript><img src="https://www.youredm.com/wp-content/uploads/2015/04/64-twitter1.png" alt="Follow Us on Twitter" border="0"/></noscript></a>&nbsp;
<a href="https://soundcloud.com/your-edms-collection" target="_blank"><img class="lazy lazy-hidden" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2015/04/64-soundcloud.png" alt="Follow Us on Soundcloud" border="0" /><noscript><img src="https://www.youredm.com/wp-content/uploads/2015/04/64-soundcloud.png" alt="Follow Us on Soundcloud" border="0"/></noscript></a>&nbsp;
<a href="https://www.youredm.com/feed" target="_blank"><img class="lazy lazy-hidden" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2015/04/64-rss.png" alt="Keep It Old-School on RSS" border="0" /><noscript><img src="https://www.youredm.com/wp-content/uploads/2015/04/64-rss.png" alt="Keep It Old-School on RSS" border="0"/></noscript></a>
</div>
</div>
</div> </div>
<div class="cb-two cb-column clearfix">
<div id="nav_menu-3" class="cb-footer-widget clearfix widget_nav_menu"><h3 class="cb-footer-widget-title cb-widget-title">Discover Our Team</h3><div class="menu-bottom-menu-container"><ul id="menu-bottom-menu" class="menu"><li id="menu-item-69447" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69447"><a href="https://www.youredm.com/contact-us/">Contact Us</a></li>
<li id="menu-item-104515" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104515"><a href="https://www.youredm.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-232525" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-232525"><a href="https://www.youredm.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-232529" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-232529"><a href="https://www.youredm.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-207233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-207233"><a href="https://www.youredm.com/partners/">Partners</a></li>
</ul></div></div> </div>
<div class="cb-three cb-column clearfix">
<div id="text-49" class="cb-footer-widget clearfix widget_text"> <div class="textwidget"><a href="https://www.youredm.com"><img class="lazy lazy-hidden" src="//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.youredm.com/wp-content/uploads/2014/08/yedmlogo5.png" alt="Your EDM" border="0" /><noscript><img src="https://www.youredm.com/wp-content/uploads/2014/08/yedmlogo5.png" alt="Your EDM" border="0"/></noscript></a>
<br /><br />
<i>&copy; 2019 Your EDM, LLC - All Rights Reserved</i>
<br /></div>
</div> </div>
</div>
</footer> 
</div> 
<span id="cb-overlay"></span>




<script type="text/javascript">
var sc_project=8067188; 
var sc_invisible=1; 
var sc_security="9a21a678"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="hits counter"
href="http://statcounter.com/" target="_blank"><img
class="statcounter"
src="http://c.statcounter.com/8067188/0/9a21a678/1/"
alt="hits counter"></a></div></noscript>

<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/5836/tag"></script><script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var a3_lazyload_params = {"apply_images":"1","apply_videos":""};
/* ]]> */
</script>
<script type='text/javascript' src='//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extra.min.js?ver=1.9.3'></script>
<script type='text/javascript' src='//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.srcset.min.js?ver=1.9.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var a3_lazyload_extend_params = {"edgeY":"400"};
/* ]]> */
</script>
<script type='text/javascript' src='//www.youredm.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extend.js?ver=1.9.3'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-content/themes/revfour/library/js/cookie.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/comment-reply.min.js?ver=4.9.13'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-content/themes/revfour/library/js/jquery.fs.boxer.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-content/themes/revfour/library/js/cb-ext.js?ver=1.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cbScripts = {"cbUrl":"https:\/\/www.youredm.com\/wp-admin\/admin-ajax.php","cbPostID":"253079","cbFsClass":"cb-embed-fs"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.youredm.com/wp-content/themes/revfour/library/js/cb-scripts.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='https://www.youredm.com/wp-includes/js/wp-embed.min.js?ver=4.9.13'></script>
<script>
console.log('US')
</script>

</body>
</html>